Wednesday, February 27, 2013

Debian Wheezy - feather light and rock solid


Question: Why do I like Debian?

Short Answer: It gives me a "Debbie Does Dallas" experience. Addictive like pristine porn - no nonsense and predictive. The rest gazillion other lady-like distributions invigorate you with too much Viagra but don't show up at THAT moment.

Long Answer: Read this review and/or comb the web for so many other reviews.

From early days, sitting on version 4.0, that's right Etch, it flirted me. It was neither too easy, nor too beautiful, but always rock solid. Then followed Lenny and Squeeze only to reaffirm and sometimes spice up that experience.

With that prelude follow the run.

Wheezy from it's very alpha and beta phases put so many Debian lovers into suspicion. Whether it'll default to XFCE or Gnome; why it jumped into that gnome 3 mess; and if it'll stick to the proclaimed "2-years - one release" schedule. With the release of RC1 it certainly proved that it sticks to the schedule. Also confirmed that gnome3 is not that much of a holly mess the jerks make it out to be. Little obsolete as per Fedora and Ubuntu standards, but the latest Debian is very modern and polished.

Installation

After cd/dvd drive started behaving mad while still under warranty I didn't go for a replacement. Not wise to add to plastic waste. Better use USB drives - for sharing data and creating bootable media. Debian is infamous for creating USB bootable media. Unetbootin didn't work as expected. But now you don't need it anymore. Bytecopy procedure works like a charm with netinstall images. I picked up a 64bit all-nonfree-firmware loaded netinstall image and created a usb install media with dd. In my case, it was:

dd if=firmware-wheezy-DI-rc1-amd64-netinst.iso of=/dev/sdc bs=4M; sync

Change the device options as per your setup.

Butter smooth install routine, as expected from a Debian installer! I chose my first SSD, an OCZ Octane SIII as / partition and dedicated a donkey 2TB WD HDD for /home. No swap (who needs swap when you've 16GB of RAM). Went for some SSD options - noatime and discard. Then followed the sane default package selection and user account creation, MBR selection, et al. Boring, it may sound, if you're accustomed to ugly surprises during installation.

Install routine completed. Poweroff. Night set in. I went to bed.

Post Installation

Next morning I woke up to a nice Debian Wheezy on gnome-shell. Seductive as they say, but not slutty. Never experienced any crash, gnome-shell nuisance or kernel-panic stuff. There were some minor annoyances which I hope will be fixed with the Final Release. Mind it, it's still an RC1!

Everything worked. Network sharing with Windows 7 on my Asus EEE 1215b, data sharing with my ntfs partition on Windows 7, mac filesystems on a hackintos (never tell mac people), on that same machine. Then some more, bluetooth, WiFi and all.

For the first time, multimedia experience was very smooth. Just install libavcodecs-extra package and you're there. Throw anything at it, it plays. And for those abominable porno stuff with some esoteric format there's always the venerable VLC. In short, the days of bad multimedia experience is over. Basement dwellers and FOSS purists may complain though, for this non-free move.

Resource Usage

Very frugal. No sudden clock ups and downs. CPU stays at ~1-5% throughout till you don't burn it with intensive gaming, program compiling and media encoding.

Very low footprint of memory. Freshly booted system uses ~320MB, with all effects - bells and whistles on and mysql, apache services (and what not) still enabled (for my wife) on runtime.

Do that foreplay. Fix bugs and bad things!

Wheezy at RC1 has its share of bugs and problems. However, none is a showstopper. You can live with them without any fix, cos most of them will be fixed automatically in the Final Release. If you like you can fix them very soon with a few minutes of dirtying your hands in the command line. First fire up terminal and be a root user - use su or sudo, whatever you're used to.

#1 - "cannot set freq 16000 to ep 0x86"

During booting the screen fills with "cannot set freq 16000 to ep 0x86" error messages and stops for around 4 secs (it might vary in your case) and then the login windows appears. This bug is related to Logitech HD quickcam. The easiest fix is to update kernel from Unstable Repository. Enable unstable repo in /etc/apt/source.list. Upgrade kernel and disable, or better delete that entry from the sources.list. Never fiddle with testing and unstable. 

#2 - no sound

While Intel Azalia HD sound card worked nice on first boot, consequent boots were without any sound while the audio mixer button was still showing active.
Permanent fix for this annoyance is to put:

options snd-hda-intel model=generic

at the end of /etc/modprobe.d/alsa-base.conf

#3 - enable poweroff option:

Default gnome-shell 3.4 doesn't show poweroff option if you don't press Alt key with still point the mouse to the suspend option.

The easy fix is to edit /usr/share/gnome-shell/js/ui/userMenu.js

Look for "this._haveSuspend = this._upClient.get_can_suspend();" and replace the same with "this._haveSuspend = false;" (don't use those quotes, they're here to distinquish commands/config text from human English)

#4 - [warn] PulseAudio configured for per-user sessions ... (warning)

This pulse audio message is not fatal. But you can fix it too:

edit /etc/default/pulseaudio 

look for 

    PULSEAUDIO_SYSTEM_START=0

and change it to

    PULSEAUDIO_SYSTEM_START=1

That pretty much ends this review.

Share your thoughts